[小ネタ]EclipseでGradle IDEをインストールした際に「Could not determine java version from ’xxx’」と言われたら

[小ネタ]EclipseでGradle IDEをインストールした際に「Could not determine java version from ’xxx’」と言われたら

この記事は公開されてから1年以上経過しています。情報が古い可能性がありますので、ご注意ください。

Gradle IDEをインストールしたらエラーに

諸事情により Eclipse + Gradle IDE環境を使用しなければならなくなり、
ひさびさにEclipse(Mars)をダウンロードしてきてセットアップしました。
しかし、Gradle IDE pluginをインストールしたところ、下記エラーが出現。

An internal error occurred during: "Update Gradle Classpath for your project".
Could not determine java version from '9-ea'.

Java9はダメですよーっていわれて正常に動作しません。
Java9なんていれたかなあ・・・と思いつつ、下記コマンドを実行して確認。

% /usr/libexec/java_home -V 
Matching Java Virtual Machines (2):
    9, x86_64:  "Java SE 9-ea"            /Library/Java/JavaVirtualMachines/jdk-9.jdk/Contents/Home
    1.8.0_51, x86_64:   "Java SE 8"   /Library/Java/JavaVirtualMachines/jdk1.8.0_51.jdk/Contents/Home

たしかに入ってました。(たぶんこれ確認したときだ) 今は必要ないので、アンインストールします。

% sudo rm -rf /Library/Java/JavaVirtualMachines/jdk-9.jdk/

アンインストールはこれだけでOKみたいです。
これで無事Gradle IDEが動作するようになりました。