jQuery 2.0 リリース

jQuery 2.0

jQuery 2.0がリリースされました。jQuery 2.0は、最新ブラウザ向けに作られています。
古いブラウザをサポートするには、jQuery 1.xを使うことです。また、jQuery1.xは今後もサポートされていきます。

jQuery 2.0で変わったこと

IE 6/7/8はサポートされていません。
分岐する必要があります。

<!--[if lt IE 9]>
    <script src="jquery-1.9.1.js"></script>
<![endif]-->
<!--[if gte IE 9]>
    <script src="jquery-2.0.0.js"></script>
<![endif]-->

JSファイルサイズ縮小

jQuery 2.0.0ファイルは、IE6,7,8の撤廃のおかげで1.9.1ファイルよりも12%小さくなっています。

カスタムビルド

オプションのモジュールを除外しJSファイルを小さくできます。
https://github.com/jquery/jquery#how-to-build-your-own-jquery
githubにソースがあります。
https://github.com/jquery/jquery

jQuery1.9とAPIが同じ

jQuery1.9にアップデートしていないときは、http://jquery.com/upgrade-guide/1.9/ を参照。

ダウンロード

jQuery 2.0にアップデート

jQuery1.8以前からアップデートする際には、下記を参照してください。
https://github.com/jquery/jquery-migrate/#readme

<script type="text/javascript" src="http://code.jquery.com/jquery-2.0.0.js"></script>
<script type="text/javascript" src="http://code.jquery.com/jquery-migrate-1.1.1.js"></script>