WARN [@vue/compiler-sfc] という大量のアラートが出た話

2022.07.25

私が担当している案件では、Vue.js、Nuxt.js を使って開発しています。 先日、npm install した後に npm run dev したところ以下のようなエラーが大量に出ました。

WARN [@vue/compiler-sfc] ・・・

原因を調べたところvueのバージョンが 2.6 から 2.7 にあがっていました。2.6までは vue-template-compiler というコンパイラだったのですが、2.7 から compiler-sfc というコンパイラに代わったようです。

package.jsonを

"vue": "^2.6.14",
"vue-server-renderer": "^2.6.14",
"vue-template-compiler": "^2.6.14",

から

"vue": "~2.6.14",
"vue-server-renderer": "~2.6.14",
"vue-template-compiler": "~2.6.14",

にしてマイナーバージョン固定したところアラートはなくなりました 以下の記事を参考にしました。

Vue 2.7 is Now in Beta

以上になります。